by r0t,der4444,cembo,VietMafia

Wednesday, June 21, 2006

phpTRADER Multiple SQL injection vuln.

###############################################
Vuln. discovered by : r0t
Date: 21 june 2006
vendor:
www.bluehouse-project.de/index.php?area=1&p=product
affected versions:4.9 SP 5 and prior
###############################################

Vuln. Description:

phpTRADER contains a flaw that allows a remote sql injection attacks.Input passed to the "sectio" parameter in "login.php","write_newad.php","newad.php",
"printad.php","askseller.php","browse.php",
"showmemberads.php","note_ad.php","abuse.php",
"buynow.php","confirm_newad.php" and input passed to the "an" parameter in "printad.php","note_ad.php" and input passed to the "who" parameter in "showmemberads.php" and input passed to the "adnr" parameter in "buynow.php" isn't properly sanitised before being used in a SQL query.
This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

###############################################
Solution:
Edit the source code to ensure that input is properly sanitised.
###############################################
More information @ unsecured-systems.com/forum/

0 Comments:

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew