by r0t,der4444,cembo,VietMafia

Monday, June 19, 2006

phpMyDirectory XSS vuln.

###############################################
Vuln. discovered by : r0t
Date: 19 june 2006
vendor:http://www.phpmydirectory.com/
affected versions:v.10.4.5 and prior
###############################################

Vuln. Description:

phpMyDirectory contains a flaw that allows a remote Cross-Site Scripting attacks.Input passed to the "PIC" parameter in "offers-pix.php" and input passed to the "from" parameter in "cp/index.php" and input passed to the "action" parameter in "cp/admin_index.php" isn't properly sanitised before being returned to the user.
This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

###############################################
Solution:
Edit the source code to ensure that input is properly sanitised.
###############################################
More information @ unsecured-systems.com/forum/

0 Comments:

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew