by r0t,der4444,cembo,VietMafia

Wednesday, April 19, 2006

Plexum X5 SQL vuln.

###############################################
Vuln. discovered by : r0t
Date: 19 april 2006
vendorlink:http://www.plexum.com/network/
affected versions:X5 and previous
###############################################


Vuln. Description:

Plexum contains a flaw that allows a remote sql injection attacks.Input passed to the "pagesize","maxrec","startpos" parameters in "plexum.php" isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.


examples:

/plexum.php?section=webstats&page=hits&startpos
=15&maxrec=457&pagesize=[SQL]

/plexum.php?section=webstats&page=hits&startpos
=450&maxrec=[SQL]

/plexum.php?section=webstats&page=hits&startpos
=[SQL]

###############################################
Solution:
Edit the source code to ensure that input is properly sanitised.
###############################################
More information @ unsecured-systems.com/forum/

1 Comments:

Blogger Plexum told...

Thanks for the information; we have now released an update to correct the issues, for all using Plexum X5 are now advised to update their Plexum X5 system to 5.4.9 build.

9:43 PM

 

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew