by r0t,der4444,cembo,VietMafia

Wednesday, December 21, 2005

phpSlash SQL vuln.

phpSlash SQL vuln.

Vuln. discovered by : r0t
Date: 21 dec. 2005
vendor:http://www.php-slash.org/
affected version:0.8.1 and prior

Product Description:

phpSlash is a CMS that provides an easy and flexible means to publish websites.ddd It currently boasts full HTML templates, an OO design, the ability to operate in a hosted environment, and a bunch of other goodies..d

Vuln. Description:

phpSlash contains a flaw that allows a remote sql injection attacks.Input passed to the "story_id" parameter in "article.php" isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code

example:

/article.php?story_id=1[SQL]

Solution:
Edit the source code to ensure that input is properly sanitised.

0 Comments:

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew