by r0t,der4444,cembo,VietMafia

Wednesday, December 21, 2005

Papoo Multiple SQL vuln.

Papoo Multiple SQL vuln.

Vuln. discovered by : r0t
Date: 21 dec. 2005
vendor:http://www.papoo.org/
affected version:2.1.2 and prior

Product Description:

Papoo ist an easy to use, accessible CMS. It respects for Frontend and Administration the rules of the WCAG and ATAG. Papoo is Open Source.

Vuln. Description:

Papoo contains a flaw that allows a remote sql injection attacks.Input passed to the "menuid" parameter in "index.php" "guestbook.php" and "forumid" "reporeid_print" parameter in "print.php" isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code

examples:

/index.php?menuid=[SQL]
/guestbook.php?menuid=[SQL]
/print.php?reporeid_print=&forumid=[SQL]
/print.php?reporeid_print=[SQL]


Solution:
Edit the source code to ensure that input is properly sanitised.

0 Comments:

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew