by r0t,der4444,cembo,VietMafia

Thursday, December 15, 2005

bbBoard v2 XSS vuln.

bbBoard v2 XSS vuln.

Vuln. discovered by : r0t
Date: 15 dec. 2005
vendor:http://www.bbv2.com/
affected version: v2.56 and prior

Product Description:

bbBoard v2 is the best message board software, guaranteed*! bbBoard is completely customisable and code-modifiable, in various languages. Because of bbBoard's clean interface and auto-installation and updation features, it makes it an uncomplicated tool for even the novice computer user! bbBoard can be accessed using a cellular phone (WAP), NNTP, Telnet, and MSN Messenger. And you still can interact by posting, sending PMs, using the Chat feature, visiting the Calendar or posting a webcam recording.

Vuln. Description:

bbBoard v2 contains a flaw that allows a remote cross site scripting attack. This flaw exists because input passed to search module paremters isn't properly sanitised before being returned to the user.
This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.


Solution:
Edit the source code to ensure that input is properly sanitised.

0 Comments:

Post a Comment

<< Home

 
Copyright (c) 2006 Pridels Sec Crew